The community forums are in BETA and closed to the public.

java.lang.VerifyError: com/pubnub/api/PubnubCore while running on Android over 1.8 and 1.7 java

I am trying to run my application using Pubnub on Studio, my project is exceeded 65k so added multidex and added dependencies for multidex also. Not project is only running 5.0+ devices. If I run below 5.0 devices I am getting below exception.

java.lang.VerifyError: com/pubnub/api/PubnubCore at at at at$1500( at$H.handleMessage( at android.os.Handler.dispatchMessage( at android.os.Looper.loop( at at java.lang.reflect.Method.invokeNative(Native Method) at java.lang.reflect.Method.invoke( at$ at at dalvik.system.NativeStart.main(Native Method)

I was running Java 1.8, then I tried running on 1.7 still I see same issue.

Can you please respond ASAP.

Can you submit this to support where we can more efficiently track and resolve this issue. Many thanks!

Comments to this discussion are now closed!